9th Feb 2003, 10:14

My wife also has a 99 Taurus that has the dome light problem. I will certainly try lubing the door latches. The car has 65k miles and has had the steering rack replaced twice, once at 20k miles under full warranty and once at 58k where Ford paid 80% of the repair, including the tow charge. Ford knows there is a problem with the racks and if the customer complains loud enough will pay part of the bill even if you are well out of warranty.

10th Feb 2003, 12:25

Regarding the problem of the dome light staying on. I sprayed every door latch with a generous dose of WD40. Within a few minutes the dome light went out. Thanks for the tip.

22nd Feb 2003, 21:45

Thank you SO much for the tip about solving the "dome light/door ajar" dilemma. I have a 1997 Mercury Sable with the same problem...the car was sitting in the driveway tonight, and after THIRTY minutes, the dome and interior lights still would not turn off! As per your instruction, I used spray lubricant on the latches of the driver and passenger-side doors, and *poof*, the interior lights turned off. Again...thanks!

18th Mar 2003, 11:30


I just had the same dome light problem with my 99 Ford Taurus wagon. I was so upset due to the fact that I just made my last payment on it, and boom, here come the problems. I read all your advice on the WD-40 lubricant and to spray it on the door hinges, and like magic, the light went out and the door ajar light also went out! I cannot express how relieved I am that I didn't have to take it in to the dealer and be charged hours of labor!

Thank you.

Anne R.

8th May 2003, 22:17

I've had some problems with my Taurus too.

The worst areas:

Heater core


Headlight lenses

A/C Problems (though have original compressor)


Agree with other; it handles like a dream. I have had to change out most replaceable parts, except light bulbs seem to last a long time.

About 40K miles ago I had to have the transmission rebuilt. Did I mention mine is a 1989, purchased in late 1988. It has 241K mostly city miles and I'm the mechanic.

Something needs changing as I have a vibration in the front end that none of the standard things seems to fix.

Advice anyone?

WSGJ, Greenville, Tx.

12th Jun 2003, 17:39

I have a 1986 Ford Taurus and it is a great car to own. I have had steering problems and this was fixed several years back. That noise when you turn the car either way has always been in my Taurus from conception. I now think I may have another problem with the power steering as the fluid has gone black and periodically I am hearing interesting noises emanating??fromthe right side of the car. Have had to replace those pesky tie rods and a transmission (under warranty) and the brakes. You know for all the problems, which is not the Taurus's fault, the car runs well and passed a safety and emissions test this year. Yes, I would get another Ford Taurus-no question!! Mary Lynn

p.s. If anyone knows about power steering, please let me know if the power steering box makes a noise. Thanks.

16th Sep 2003, 17:47

I have a 1999 Ford Taurus. At 55K miles I had to have the steering rack and power steering pump replaced, fortunately I had purchased an extended warranty, so Ford covered everything including a rental. Shortly after (about 2 weeks) the repair, I started having a problem when starting the car. It will start and then die. The only way it will remain running is if I keep my foot on the gas. I'm not sure what to do, but am sure this is probably not covered under warranty. If anyone has had this problem before with his or her Taurus, please let me know what causes this to happen.

This car was bought used with very few miles on it back in 2000 by my parents. The only problems they seemed to have had before I took it in 2002 were warped rotors, and an alignment problem. I have been driving it for 10 months with no problems until now as I have described above. Sorry this is so long. I would appreciate any advice I receive.

29th Sep 2003, 11:41

I have a 99 ford and it shudders going into 3rd gear anyone else have that prob.?

9th Dec 2003, 18:59

Don't you just LOVE the internet! I was having the dome light issue and thanks to you guys $.05 worth of WD_40 solved the problem! Thanks!!!

26th Mar 2004, 12:22

When I turn my wheel to the left when I make a turn I also get that hideous noise. I'm not sure what it is, but I just had my rack and pinion replaced because there was puncture in one of the boots and it was shooting power steering fluid all over the ground. It was bad. Now I've got the dome light problem, and I'll try the WD40.

When I first got the car it was real solid, and responsive, now after some many miles 70K+ the car has felt like it's coming apart at the seems. It just shudders and you get wind noise, and it shakes once you get to 65+ MPH. It just freaks me out, I want to replace it, but American cars have a bad rep and foreign cars are getting expensive, especially if you want a good one. Angers me greatly.

12th May 2004, 16:18

'99 Ford Taurus - I purchased the car in 12/98. Until recently, I have liked the car. I just had to replace the steering rack and power steering pump. It was a $900 expense. I have driven cars for 25 years and have never had this problem happen. After reading all the other reviews, I decided to contact Ford about it and see if they would cover any of the cost (car has 109,000 miles). They said they have not been aware of this being a problem with this car and could not make any adjustment. I was disappointed with their lack of customer service.

Other problems that have also been noted did occur in my car.

1. The alternator failed at 50,000 miles. (not covered)

2. The driver's door never has shut right and could never be adjusted correctly.

3. The windshield wipers going on by themselves is driving me nuts!

I certainly would consider another Taurus and have rented the new models when I travel.

25th May 2004, 14:28

Bought 99' Taurus, 7-4-99.

Rotors were warped @ 10k - had them turned - warranty.

Fuel tank pressure pump failed @ 15k - warranty.

I replaced the rotors, pads and drums @ 45k.

Have right side passenger wind noise, not fixed yet.

I replaced fuel pump @ 90k.

Had problem with screeching sound from left front wheel well, had bushings lubed twice, no noise anymore.

Now have dome light problem, will try wd40...thanks.

I had original tires on the rear till 60k.

31st Jul 2004, 18:24

I am disappointed with this car. I have a 99 SE and had to replace the rotors and the pads at 40,000 and then again at 65,000 and have the grinding again now. My sterring rack and power steeing pump just went out a week ago. what is the matter with Ford, this is a real defect when will they own up to it?