2002 Isuzu Wizard LS V6 from Australia and New Zealand


Pretty good so far apart from one fault


Haven't had the car very long, but when I go from reverse to drive, it's started cutting out and the check trans light and engine light come on. Had the wiring loom done, but it has started again 2 days later.

Doesn't seem to do it when it's warm. However it does try to cut out when I'm on bumpy road (main street, not gravel).

Has anyone else had this problem? I'm covered under warranty for now, so wanna work out the problem before that runs out and I have to pay.

General Comments:

Quite comfortable to drive with lots of room if you have a few kids in car seats (seat belts are long enough to go around capsules).

Excellent body, no rust.

Changing to sport mode while traveling over a windy hill makes a big difference to the stability.

Would you buy another car from this manufacturer? Don't Know

Review Date: 13th May, 2015

2000 Isuzu Wizard 3.0 turbo 4JX1 from Australia and New Zealand


Good car, badly built engine


Injector pump failed.

Oil pressure problems.

Starter motor failure.

Water leakage.

Intermittent ABS warnings.

Final straw; cracked cylinder head.

The vehicle was nice to drive, powerful, quiet, and economic on fuel

It towed very well, though was very slow and hard to start.

4JX1 engine is a failure.

Wrote the vehicle off as it is too expensive to fix, and who wants the trouble?

Would you buy another car from this manufacturer? Yes

Review Date: 2nd December, 2012

2001 Isuzu Wizard 3.0 4JX1 from Australia and New Zealand




The biggest piece of rubbish I've ever owned!

Hard starting, glow plugs snapped off in the head. Expensive to repair...

Injector seals leaked, replaced injectors and sleeves.

Oil pressure sensor leaks, damaging injector harness.

Oil pick up o-rings failed, sucking air.

Using the correct oil, the vehicle still has the same problem...

Gearbox changes gear randomly.

Elect suspension failed, massively expensive to replace.

TOD failed, no-one can sort the fault out, engages TOD when driving up a slope, causes a banging in the transfer case.

Alternator failed.

Wipers stopped, was the body module $$$$$.

General Comments:

Never buy one, unless you want to waste lots and lots of time and money.

I would never buy another Isuzu because of this vehicle; these failures are not acceptable with the normal standard of Japanese engineering.

Would you buy another car from this manufacturer? No

Review Date: 10th November, 2010

1999 Isuzu Wizard 3 litre turbo diesel from Australia and New Zealand


Good value 4WD


After about 10,000ks, the engine refused to respond to the accelerator. After much back a forth to servicing, the agents 2nd upgrade to injectors was done at my cost.

Since then one rear wheel seal kit. Regular oil and filter changes, but otherwise only service.

Eleven litres per hundred Ks normal average fuel consumption. Can be less than 10 on long runs lightly loaded.

General Comments:

Wizard is used as a hack to tow boat trailer, 1.5 ton, and as a general run about

Still have my V8 Soarer after 11 years, great engine.

Would you buy another car from this manufacturer? Yes

Review Date: 13th May, 2007

14th Oct 2014, 03:34

I'd like to add to my previous review from back in '07.

Had to have a rebuilt ABS module; that cost about $1200.00 plus about $600 to finally get the problem diagnosed. That was in 2010.

Body is fine, no rust. Went to Kaitia & returned from Auckland in June. Purchased in 2002, first N.Z owner, 73,000km. Had to pay for the injector upgrade soon after, so I missed out on the factory recall later.

It's now done 230,000km, just tyres and the usual oil & filter changes.

1998 Isuzu Wizard 3.0 turbp diesel from Australia and New Zealand


Good family car


Have had the injector recall done 4JX1 motor. Also had to have the oil sensor and wiring harness replaced (oil rail pressure sensor leaking oil into wiring harness)

Water pump replaced 81,000 ks.

Currently have a problem with vehicle just cutting out, immediatly (not a fuel problem, oil pressure to injector rail all OK) it will restart straight away then run and then cut out. Tech 2 computer says no trouble codes.

Any others had this problem? Would be interested in feed back to help fix problem.

General Comments:

Has been a great family wagon apart from above.

Would you buy another car from this manufacturer? Don't Know

Review Date: 26th March, 2006

11th Jul 2006, 22:17

When was the motor recall for the injectors?

9th Jun 2008, 03:19

Have just encountered the same problem; fixed by tightening the earth cable from the computer to the gear box.

26th May 2009, 20:58

Same work done as above, my problem is when the vehicle stands for 3 to 4 hours, it will start and idle OK, but there is no throttle response for about 20 seconds after putting into drive. The vehicle has been back to the agents six times without any improvement.