12th May 2005, 14:49

This is in response to the question about the rear windshield wiper... I just took my car in for an inspection and asked about my rear wiper which also died. It so happens that I also have a 1998 Grand Cherokee 4x4. Dealer said I have to have the whole motor replaced. I took it to Midas and we:

1. Turned the car on

2. Turned on the rear wiper via dash control

3. Helped the wiper move by carefully moving it back and forth WHILE spraying with some WD40.

4. Did this for about 5 minutes.

5. Problem fixed.

Hopefully it's that easy for you.

P.s. I now don't like dealers...

7th Jun 2006, 13:42

My son owns a 1997 Jeep Grand Cherokee Laredo and the rear end is out on it. We purchased a new pin and gears, but do not know how to rebuild it. Anyone have a site with instructions or have instructions they could email? would really appreciate seeing on how it would cost an arm and a leg to put in a shop. You can email me at offlimits_2u@hotmail.com.

5th Aug 2006, 19:03

We bought a 1997 Grand Cherokee Jeep and experienced the recall B02 which we had no knowledge about. I placed the car in park and it seemed stable. While it was still running, the car unexpectantly moved rearward and crashed. Chrylser denyed our claim for help with the repairs and we are out a car along with damage to our garage. I don't even recommend buying Chrysler. We learned our lesson not to.

28th Apr 2008, 15:21

Buying a Chevy Equinox would be like jumping out of the frying pan and into the fire. Try a japanese truck if you want reliability.

4th Nov 2009, 00:08

My dad has a 97 Grand Cherokee, and it's at about 290,000 miles. The major things that have gone out on it were the computer and the transmission (but that was because he put the wrong fluid in). Overall, it's been an amazing vehicle!

15th Dec 2010, 10:56

I have a 1997 Jeep Grand Cherokee Laredo with 130000 miles and I find it to be one of the best vehicles I ever owned. It has been my most reliable car I ever owned. Maybe I am just lucky and I know I would buy another Jeep.


6th Dec 2011, 05:47

The rear wiper motor of my 97 Jeep Laredo went on the fritz. I have picked up two different ones at junk yards, and they don't work either. I am wondering if I am hooking them up wrong? When holding the motor in my hand, the electrical connectors are facing me. The wiper shaft is on the top. There are 6 electrical connectors in the plug. 2 rows, 3 connectors in each row. The top center connector is power on, the top left connector is ground, the bottom left connector is ground, the bottom center connector is ground, the bottom right connector is power delay, and the right connector is unknown.