2003 Mitsubishi Eclipse GS from North America - Comments

22nd May 2007, 11:43

Mitsubishi is a disgrace to Japanese Engineering.

2nd Apr 2008, 07:35

My AC died also at about 55,000 miles.. I never replaced it.

My 01 eclipse GS currently has 235,000 miles and no repairs to date just service. I am buying an 03 GTS today.

8th Jan 2010, 17:55

I've had my 2003 Eclipse GS for 5 years now, and it is pretty cool.

The problem I encountered is the air conditioning was leaking on the driver's side floor, and my mechanic said that the tube carrying the water was to thin and would clog. That was fixed.

Also my sunroof button gets displaced, my dashboard is cracking because of the heavy south Florida sun, my trunk also does no open properly, which is probably caused by the unbalanced weight of the spoiler, and my check engine button is constantly on and nothing is wrong with the car.

I love driving it in the city because it is fast, and on the highway because it is smooth.

I do not like that I cannot see the traffic in front of me because it is low, but that's the disadvantage of a sports car.

Now I am thinking of either getting a new Eclipse with the V6 engine, but they are very scarce, or a used BMW 330 coupe.

24th Jul 2010, 17:04

Convertible top not working at all??? Check behind your driver's side brake light and make sure the switch is turned on to automatic, and not on manual. I know this is a very small chance, but it happened for me. I bought my Spyder with the top not working, and it was the switch turned off (it just had a new top put on it before I bought it).

2nd, if your check engine light stays on, but the car runs fine, most likely it's an 02 sensor. Have Discount Auto Parts read your computer for free, and if it is, you can just unplug your negative battery terminal for a minute, and it'll reset your computer and your car will run fine again (if it resets the code). Mine won't go off for at least a couple weeks at a time, so why spend 70 bucks on a sensor.. it started going off when I put Lucas fuel treatment in the car; maybe it burned off some carbon that set the sensor off...

Hope this helps someone. I just bought my Spyder a few months ago, and it's been a great car; very reliable.

Add another comment

Note: A Comments RSS Feed is available. New comments appear in the Members Area before the main site