1989 Chevrolet Celebrity Eurosport from North America - Comments

5th Aug 2007, 20:58

I now drive Mom's beloved Eurosport. She bought it new-used (a left-over demo) in 1989. This is one car that won't quit. It starts reliably and gets me to work every day. Amazingly, this car still gets good gas mileage! Mom's only complaint was that the paint peels away, requiring occasional "Maaco Make-overs." The body has been quite rust-free and hopefully the bottom won't drop out! When that happens, the Chevy and I will part company.

14th Jan 2009, 11:47

So I randomly got on here to see if my Celebrity entry was still on here, and uhh it is. Even though it's been like four years...

I only had this car for a year, and in that time I did everything I could think of to kill it. Neglecting oil changes, hard acceleration, shifting from Drive to Reverse while driving...

NOTHING would kill this thing! So then I sold it to a neighbor, where I STILL had to look at the stupid car every day, until very recently actually WHEN it did die.

Moral of the story: Chevy Celebrity's are possessed and will run until the end of time.

22nd Mar 2009, 08:40

I bought my 89 Celebrity wagon in 2001 with 97,000 miles on it. It was my daily driver for 6 years with regular trips up and down the east coast from New York to Florida. It never missed a beat. I moved out of the country in 2007 and donated to my pastor who gave it to his son-in-law. When I parted it with it... it had 255,000 miles. It still looked and ran like it did when it was new. I took real good care of it and had it repainted in 2004. The last time I spoke to my pastor, he said it was still going strong and approaching 300k. The only complaint I ever had was the computer was prone to problems and was in an awkward place to get at. I replaced it twice.

23rd May 2009, 21:45

I bought a 1989 Chevrolet Celebrity (eurosport) 4 cylinders 2.5 about 4 yrs. ago.

It ran beautifully until about a year and half ago.

I replaced the computer and the PROM chip was put in the new computer. I have also replaced the coolant sensor, but the ECM still does read it.

I had to have new crankshaft sensor or the crankshaft itself.

The mechanic cost me $350. I need to drive this car. Please tell why it stops when I cruise in 3rd gear.

Add another comment

Note: A Comments RSS Feed is available. New comments appear in the Members Area before the main site