21st Jan 2002, 20:17

The engine in the Zx 16valve is not the same as the 405 Mi16.The Mi16 unit is 1903cc and is designated D6C or XU9J4.

This is the same engine as used in the Citroen BX16valve, and produces 160bhp@6500rpm, and 133lbft@5000rpm.

The ZX engine is 1998cc and produces 155bhp.

24th Jan 2002, 08:56

Does anyone know how difficult it is to change the clutch cable on a ZX? I have a 1.9 diesel.


9th Feb 2002, 09:03

Regarding the mi16 engine, did any one tried fitting this one into a zx?

I own a zx 1.8 (furio), is it worth doing? are there any problems?


11th Feb 2002, 18:10

The Mi16v post 1993 did use the same 155bhp 2 litre engine as the ZX 16v and the S16 306.

I have owned both a 1992 - Mi16v - this has 160bhp and a 1995 ZX 16v.

The Mi16v seemed to be more peaky - the ZX between 1000rpm and 3000rpm is good, then it seems to hold its breath until 4000rpm - then it goes, and goes and goes... it's far too easy to bounce off the rev limiter.

Which one was best?? I still have a soft spot for the Pug - but for the money the ZX is a real "Q" car, leaving other drivers confused when you blow them away!!

8th May 2002, 13:10

I have a 1994 16V which I have had since Feb. I had a Spark plug lead breakdown and so it ran on only 3 cylinders until the fault was diagnosed and all 4 were changed as a precaution. Since then it has been running very well and I echo the comments of the author. On the open road it is a dream to drive with plenty of power for overtaking, when possible!

However since the lead changes the car has been developing a similar problem as before. Although the sparks were changed at the same time the car sometimes losses power, sounds like a VW Beetle and then runs okay again. Very Odd. Can anybody shed any light if this is common problem, if the leads are unreliable, distributor problems, injectors etc, etc. Any help would be much appreciated as this car deserves to be in top condition.


21st Jun 2002, 04:23

I have an Mi16 engine transplanted in my ZX 1.9i volcane. but I'm running on the original ZX 1.9i volcane Motronic MP3.1 ECU. it works fine.

28th Feb 2003, 08:47

I have a 1996 Zx 16V for 1 & a 1/2 years now. I crave dringing it all throughout the day. Though recently, it's been giving me rubber hose problems (I guess Citroen is not too good for tropical countries), I still like it a lot.

My recent reading about the Pug GTI6 to be more powerful than the 16V. Have any idea what I can do to get that additional boost like the GTI6? Is any of those Power Chips any good on the 16V?


1st Feb 2005, 09:49

I had a 2.0 16v ZX which I sold a couple of years ago and to be honest I didn't think that it was bad at all. I had it three years in total (and 50,000 miles) and in all that time I had only TWO problems. (1) the thermostat got stuck and (2) the fuel pump went.

Other than that the car was good. OK it looked a little funny and I always thought of it as the poor mans Peugeot 306 S16, but otherwise it was good.

Raced it on a track day and overtook an Audi A3 1.8T down the straight so its got plenty of punch. It also handles well, probably to do with the "passive" 4 wheel steering. If you enter a corner a little too fast and the corner tightens still, just keep turning that steering wheel and the next thing you know the back 'steers' round and you don't crash. Fantastic, although it is hard to tell at first if its the back steering or if its oversteer.

One word of warning. The ZX losses value quicker than a falling star - so be warned. I lost £4k in 3 years...

13th May 2006, 08:01


I have a 1994 ZX 16V, amazing car!!, after some mods the car was driving the SAME like GTI6!,I'm thinking to sell the 16V because of more place in the car for my family, the car I was thinking of is Audi A4 1.8T with some mod it easy goes up to 200H.P, until than... i got a shift light with no diagram..,any one know how to install it on a 16V?