16th Jan 2013, 20:35

Trans was replaced, and does the same thing. Torque converter tested OK. I am leaning toward the TPS voltage. Wear and tear at 100k plus means that something is worn, and it has to be a dynamic part. Mine does not do this under load pulling conditions, IE, uphill or towing when you are on the throttle. And it only does it at highway speeds. Potentiometers go bad sooner or later.

14th Feb 2014, 10:08

I have a 97 Dodge Ram 1500 with the 6 cylinder, and the engine surges/cuts out, between 15 and 18 MPH only... Any other time it's fine... Any ideas?

22nd Apr 2014, 10:48

I have a 1999 Dodge Ram Van 1500 with a 318 engine. Recently it started getting terrible gas mileage (much worse than usual). I replaced the throttle sensor and it seemed to help, but a few days later it has developed a knock in the engine; would that cause our engine to be history?


4th Oct 2014, 18:17

I have a 98 Dodge Ram V6 3.9. It has been shutting off and backfiring, and it feels like when I'm driving, like I have suddenly put it in neutral for a bit. I can try and give it gas, and it does accelerate What is causing this? I'm going flipping CRAZY.

30th Dec 2014, 00:18

My 1999 Dodge Ram 1500 Laramie had the transmission rebuilt in 2011, and it's making a loud whining noise and slips out of gear, but when it's not been cranked in a couple of days, it does fine, it shifts again, but then when it warms up, it goes out again. What should I do, or what should be done to it?

Thanks, Eric.

19th Jan 2015, 21:28

I have a buddy who has a 98 1500 V8, and it will not shift into gear at all. The plug on the wire harness is broken and wires were touching, so I killed the truck and taped them up. Anyone got any suggestions??

3rd Mar 2015, 05:33

I'm having a similar issue. My 98 Ram 4x4 has no overdrive, and the brake light and ABS light are on.

I replaced the overdrive unit, and replaced a solenoid spring.

The truck will not go into overdrive, but O/D will be on intermittently.

Any ideas?

Email me at nekathenikl@gmail.com

8th Aug 2015, 20:19

1998 Dodge Ram 1500 5.9L. Someone tried to steal it! I've replaced the key and all broken boxes on the column. I have lights outside, but no power to the starter or dash lights. No radio, and nothing on the dash. Is it the computer? Help!