1998 Isuzu Trooper 3 door 3.0 diesel from UK and Ireland


Well put together


Would not start in the morning. It needed a modification done to the injectors, but the dealer was unhelpful because it had been a parallel import. Cannot obtain a spare key because I do not have a security code and Isuzu UK do not have it.

General Comments:

Nice to drive.

Would you buy another car from this manufacturer? Don't Know

Review Date: 14th January, 2002

1998 Isuzu Trooper Duty 3.1 turbo diesel from UK and Ireland


Very reliable


Only minor faults, the volume control on the radio is faulty and the electric aerial.

General Comments:

I use this Trooper as a real "work horse". I have totally abused it, but it refuses to let me down.

It handles well for a 4x4, it returns an average of 28 mpg and cruises at 70-80mph with very little noise.

The interior could be more hard-wearing and is very dull, grey plastic everywhere!

Would you buy another car from this manufacturer? Yes

Review Date: 27th April, 2001

1998 Isuzu Trooper LS 3.5 Gas from Taiwan


Go downhill and make an over 40 degree turn with 4X4 mold the transmission will dysfunction and car still slides without power output.

Would you buy another car from this manufacturer? No

Review Date: 31st October, 1999

1998 Isuzu Trooper S 3.5 petrol from North America


Nothing at all (25k miles).

General Comments:

All around excellent design - years of minor improvements pay off handsomely. The only minor gripe I have is that the Air Conditioning is a tad weak for Arizona - definitely needs dark tints for the desert.

Would you buy another car from this manufacturer? Yes

Review Date: 30th May, 1999

29th May 2001, 13:40

The air is weak for the south and I have had problems with oxygen sensors (check engine light) starting at 40,000, as well as the ABS light coming on. I have 50,000 now, and none of this is covered under the warranty.

21st Jul 2003, 08:37

I have a 1998 Trooper with 62k miles and live in NYC. the check engine light produces a code of O2 sensors and all have been replaced. The light still comes on a week or so after reset.

1st Nov 2004, 19:25

I have the same problem with O2 sensors. I've replaced mine, and it has made no improvement. It still runs though... except for that time the fuel float got jammed and I ran out of gas.