20th Jun 2006, 13:50

When did you buy your KIA for 4,000 dollars? If it was not 3 years or newer I think you got jipped. There are better cars for the same price.

22nd Sep 2007, 13:47

I was hoping to find out why my check engine light is on. If anyone can help, I would appreciate it thanks... screamin.

17th Feb 2009, 01:05

I purchased a 1997 Kia Sephia in 2007 used. The dash was burnt from the sun, and there was a little rust on it, but it didn't bother me. I was a senior in high school, and just needed a car to take me to school and work and practices.

I have had problems off and on with it since I bought it. I can't complain too much because I only bought it for 1000 dollars, but I would like to know if others had had problems with their 1997 Kia Sephia as well?

My car shakes all the time, and sometimes stalls when idle. When accelerating, it sometimes skips. I have talked too many mechanics but they just give me ideas to what the problem could be, but nothing helps.

Please, if anyone has fixed their car, tell me what the problem could possibly be. Email me at h00vr67@hotmail.com, I would really appreciate it.

I have some money to try and fix it up, but not enough to buy a new car, so I am stuck with what I have. Email me if anyone has solutions to why these things are caused and what I should do other than purchase a new car. I already know I need to do that.

9th Dec 2010, 11:09

I recently acquired a 1997 Kia Sephia LS. It's got the Mazda-built DOHC BP-ZE 1.8L and a 5-speed to go with it.

My only beefs with the car are that it burns oil like water in the desert, the driver-side axle seal is shot and leaking everywhere, and the stickshifter linkage had to be bolted into place.

Other than that, it's a great little car. Quick as hell, gets 30 MPG, and cheap to fill up.

30th Jul 2011, 01:38

Replace wiring harness; parts and labor $200 + =.

29th Aug 2014, 06:37

My car keeps stalling out on me whenever I am going real slow or have to come to a stop. Can anyone please let me know why this happens, and how can I fix this to keep it from happening?


30th Aug 2014, 00:21

Check for a bad vacuum hose leading to the throttle body.

26th Dec 2014, 12:49

Bought a 96 Kia Sephia. Found out it has A/C but not heat! Flushed the system, heater core, new thermostat, still no heat! Anybody had this problem? Maybe a blend door??