10th Apr 2007, 18:48

To the owner from April 4th who is having problems with the car overheating whilst at rest, but fine the rest of the time - My vehicle (2000 Cavalier) had the same problem. The part that broke was the fan motor that blows air over the radiator while the car's at rest. Have your mechanic look into that part.

16th Apr 2007, 20:31

I have a 2001 Sunfire and am very frustrated with it. Sometimes it won't start - it will turn over, but not start. And it also stalls while I am driving - VERY dangerous. I've taken it to a GM Dealership twice now and they cannot find the problem. It always works perfectly for them. This has been going on for about 6 months now. It's very sporatic and doesn't happen all the time, but when it does, boy, am I scared to drive. Has anyone solved this stalling/not starting issue? If not, we should petition to GM to do something about it.

19th Apr 2007, 05:13

I have a 2001 Sunfire SE with 64K miles on it.

Sunday I was leaving a friend's house after dark when my headlights went out, luckily I was able to flip to low beams before I went off the road. My high beams had died along with my daytime running lights and a side marker on the driver's side.

I took it to my Pontiac dealer where I was told this was a common problem. The service writer had this happen to her Sunfire when it was just two years old. She had the entire headlamp harness replaced... the kit at that time cost around $250. After they looked up the part they informed me that the cost today was around $500 plus the labor to put it in.

I have had many of the other problems listed in the above comments. It seems there were common defects in this model that GM has totally ignored in any kind of recall.

This is the last time I will purchase a GM vehicle.

An interesting note; they gave me a Pontiac G-5 to use while my car was in for repair. It had 8K miles on it. While I was driving it on the expressway it began to growl at 55 mph. My guess would be it has a CV joint problem.

27th Apr 2007, 16:37

I am an owner of a 2001 Pontiac Sunfire. Recently the DRL and the high beam headlights just went out. Our check engine light randomly turns on too. I took it to the dealer and they told me I need to replace the headlight wiring harness. They said there were so many shorts in the system that it would be cheaper to replace the whole thing. They gave me a quote of $900.00. This seems to be a problem across the board for the Sunfires. GM needs a recall on this.

16th May 2007, 13:46

Hello all.

Maybe someone can help me. I have a 2000 Sunfire. On Saturday 5/12 I had my father put 2 cans of r-134a into my car. When I turn on the A/C cold air came out. I get into the car today and it's blowing hot air again. Any ideas???

29th May 2007, 10:10

I'm starting to have the same problems with the DRL's...

I am starting with GM, I firmly believe that should be the ones fixing these problems.

I had the Wiring Harness fixed when recalled and a little while after had problems with the blower motor. The fix with the blower motor involved putting foam insulation to get rid of the noises coming from the blower motor. I'm pretty sure they insulated around the wiring harness. So now I have a compounded problem with the wiring harness and the blower motor. My mechanic is going to be taking a look tonight to see how the foam insulation was installed.

9th Jun 2007, 19:30

I have a 2000 Sunfire, purchased new. My problem is the metal strip that goes across the top of the door where the window goes down - its all corroded - both sides. Has anyone else had that problem? The only other problem I've had that I've seen mentioned here is the blower switch which I've had replaced twice - so I guess I've been lucky!

5th Jul 2007, 10:06

My wife's 2000 Pontiac Sunfire GT has the same problem with the DRL. It's been to the dealer several times, had the wiring harness repaired and now they're stating "circuit 593 is showing high resistance at terminal B for DRL circuit between instrument panel fuseblock and left front headlamp." It's clearly obvious by everyone's posts that there are electrical connection/harness issues with these vehicles that GM fails to fess up to. GM should get their recall in place for their own sanity to prevent any electrical fires that could affect peoples lives.

10th Jul 2007, 17:07

I have a 99 sunfire that the a/c just stopped working. I have verified that compressor works. The light on the button comes on, and I have verified that the relay works. When I ground out the relay for the compressor it comes on. What am I missing here that could potentially be the problem?

12th Jul 2007, 21:20

2003 Pontiac Sun fire. Just adding to the 1000+ problems discussed. Drivers side headlight and high beam went out. I replaced the bulbs and nothing. I tested to see if an electrical current coming from the wiring set. Sure do. Not sure what's going on. Now the daytime light on the passenger side is flickering. I can hear the DRL clicking in the fuse box. I have replaced the battery, spark plugs and the DRL. Taking it to the dealership and expecting, as many of you have found out, a new wiring harness.

15th Jul 2007, 17:22

I bought a 99 Sun-fire GT last August and have the following problems:

A/C doesn't work

DRL's don't work

Now have problem starting, strong smell of gas and a large "pop" sound from under the hood one time when I tried to start it and last, but not least the window on the driver's side will not go down, can't budge the handle one bit.


13th Aug 2007, 11:52

I am also the owner of a 2000 Pontiac Sunfire with 66K miles on it. I purchased it used from a private seller who bought it brand new. The car was meticulously cared for (all the service receipts were in the glove compartment and it was obvious that this man treated it like his baby).

My father (who drives a 2000 Sunfire also) and I both have issues with the car feeling bumpy while we are braking. My father has had the brakes replaced on his car several times and I have yet to have mine replaced. Does anyone else have an experience with it feeling...bumpy...while braking? (if that makes sense, of course.)

Anyway, within the last few weeks my a/c has been acting odd. Strange vinegar-type smell comes from the air vents if I start my car with the a/c on full blast, and most recently the a/c won't work when I first start my car up, so I have to shut it off and then restart the car with the a/c in the OFF position in order for it to work.

To top it all off, as of Saturday (8/11) the ignition in my car got stuck in the RUN position and refused to shut off at all. I had to stall my car in order to get the engine to stop running, but that of course left my battery running and PASSLOCK stepped in and now refuses to allow me to start my car. The tow truck came & picked it up this morning to take it to the dealership and I'm awaiting word on how bad it is.

Other than those problems, I have not encountered any others (knocks on wood).

Feel free to email me if you have any advice or would just like to vent about your car.