2007 Volkswagen Polo S 1.4 16v from UK and Ireland

Summary:

Lovely looking car, but constant problems

Faults:

EPC light, engine emissions light and ABS lights randomly come up on the dashboard.

Car is now shuddering.

General Comments:

For about a year now, the ECP, ABS and engine emissions lights are constantly coming on and off on the dashboard. I have took it into my garage about 3 times, and they have said there is nothing wrong with the car!

Now my car has started shuddering whilst I am driving it, particularly after I change gear and when I slow down.

It seems that a lot of people who own Polos have been having these problems with the lights and shuddering. Does anyone know what is the cause!

Please help!!!

Would you buy another car from this manufacturer? Don't Know

Review Date: 28th July, 2007

22nd Jan 2008, 09:32

I recently purchased a Polo 1.2SE registered in March 2007 and had similar problems to yourself. The temperature coolant warning light came on, then went off and came back on again, sometimes even when starting up on a morning. The dealer changed the Coolant Levels and said it was now fine. Well it wasn't. Back in it went, they couldn't find anything wrong, I told them that quite clearly there was and I was not taking it back until the problem was rectified. After further tests it was discovered there was a fault in the dash panel, which was replaced. Two weeks later and it fingers crossed all seems OK. You could try mentioning this to them, it's worth a go.

5th Jul 2009, 18:08

Again. As I have said many times on this forum. Avoid VW. Great cars but crap reliability and dealer service. Just got my car back from my dealer today after its' fourth warranty claim in seven months. They damaged it, (scratched bumper and wing). They offered me a free car wash!!! Say no more... Never again. I can hear a Honda calling...

23rd May 2012, 09:34

I also had it before, and replaced the throttle body on the intake, and then it was just fine.