2004 Ford StreetKa Winter Edition from UK and Ireland - Comments

19th Sep 2008, 10:20

I bought my 04 StreetKA 4 weeks ago. It has been fine until today when suddenly the alarm has started going off when I lock the car. I have read all the comments here and it appears to be a common problem with the StreeKA's. Does anyone know what I need to do to fix it? Is there a sensitivity wheel or anything which could lower the sensitivity of the alarm etc?

9th Oct 2008, 04:33

I have owned a 55 plate from new initially the car was great, however in the past year I have experienced various faults:

The air conditioning is like an oven; when I reported this fault to the dealership, they couldn't find anything wrong as when the engine is running stationary it is fine.

The alarm - as mentioned in various other articles above this intermittently goes on before I even reach my front door.

The alternator - 5 weeks out of warranty and under 25,000 miles it now needs replacing. I went to my dealership yesterday (as my ignition light wouldn't go out); they said that the car would be fine to drive and to return the car this morning so they can look at it. Unfortunately my car gave up the ghost last night on a county lane. Being a young female driver alone, you can imagine I was less than impressed and have now been told that I need to pay over £300 for surely a manufacturing fault. I have seen various other people with similar complications and I'm happy to make Ford fully aware of this...

9th Nov 2008, 10:18

Hi,

My girlfriend's Streetka has the alarm problem.

I've found it happens usually when the roof has been down and is put back up before the alarm is turned on.

To solve this I've found that when the roof is put back up, turn the engine on for a few seconds, turn off then put alarm on.

I've had no problems this way.

Has any one got a wiring diagram for the hardtop heated screen?

10th Nov 2008, 18:24

Hi, I have had my 03 StreetKa for two and a half years. I have read all these comments and have had all these problems; the alarm one they fixed at TAW by replacing a switch where the back panel flips up where the roof goes down, that was under warranty.

The misfiring was down to the fact I needed to change my coil packs and leads, which sorted that out, and the loss of power was due to the O2 sensors on the exhaust. I did replace both of mine because they said it would have a much better effect; it has totally sorted it out and I just put it all down to wear and tear.

The car has been a brilliant car, and I will miss it when I sell in January.

I do however need a new roof as some one slashed it open, and I don't have a clue where to go, so if anyone has any ideas, please let me know.

24th Nov 2008, 09:19

I brought my 04 reg StreetKa in January 08. I absolutely loved it!! But because it was so thirsty on the fuel and the tax was so high (£205) for the year, when I decided to buy a house, I thought I would trade my car in for something 'sensible' so in September I went back to the dealer where I brought it from, only to be told it had lost £2000 in price, which I wasn't happy about, so I decided to keep it.

But now when I am driving along, the car keeps losing power! (very scary when I'm alone in the dark down country roads). The car is under warranty so I took it into my dealer, only to be told there is nothing wrong with it!! And still the problem continues.

8th Dec 2008, 08:26

My daughter's StreetKa has had an alarm fault for a few weeks. This week, she went to start it, and the battery was flat. Inspection revealed that the boot light switch on the boot lock had come adrift, and was the cause of the flat battery (light on all the time in the boot) and the alarm going off all the time too!

9th Feb 2009, 17:17

I have a 53 plate, which I can't open the boot on the fob now, and the alarm goes off each time I lock it! - driving me crazy!

11th Mar 2009, 10:11

I have read all the comments and I find it rather scary, as I have just purchased a winter edition

StreetKa convertible 8 months ago, and I have never been able to get into the boot, only by using my key once in the car.

I will share a story with you that just happened yesterday, and it was a total nightmare. I had just come out the gym, and both my doors would not work, as the handles seemed very loose. I phoned the AA and they were totally perplexed by the situation and unable to help. Eventually after waiting 7 hours for any resolution, the car was towed to the dealer and they managed to eventually get in, but not until the following day... I had no money, house keys or any proof of identification, as it was all in the car... so you can imagine my dilemma I had.

Then I got told it was the rods in my doors that needed sorted, and funnily enough they are not covered in the warranty, and even though they only cost £30 each door, the total amount was £273.00, due to labour charge.

I am beginning to regret my decision to upgrade, as they have found other faults, with the brake pads and the front bush.

Thanks for listening to my rant x.

24th May 2009, 07:58

I brought a Street KA 03 Plate - second hand! I've had nothing but trouble with it since I bought it.

First of all, the battery light and ABS lights would come on and remain on all the time (not actually meaning anything), then along with that the dials would lose power and it would say I was traveling at 0mph, with no revs and no petrol - which I obviously wasn't. Garage sorted it - free of charge (still under their warranty) apparently something to do with alternator and some sort of overcharging problem!

NOW, just to top it off - I've having the alarm trouble that everyone has described! Can't work it out at all... it's really annoying me now and I'm starting to wish I hadn't purchased it! Although I love it when the sun shines!!! And that's all, oh and it coped very well with the very heavy snowfall in February of this year too. That's all.

24th May 2009, 15:40

I purchased my 53 plate Streetka in March this year, as I fell in love with it when I saw it. After a week it had been in the garage 4 times!!

Engine management light constantly going on, alarm going off, windows leaking, spare wheel cradle snapping, door handles stiff... I could go on and on.

Anyway, took it back to the dealer, they fixed everything, albeit eventually. Put engine management light fault down to a sensor not being correctly set, this sensor was only installed 2 days after getting the car. Alarm was the same problem, some sensor, spare wheel cradle was rusty, and handles were loosened...

After being back to my Ford dealer on numerous occasions, things look to be good and I love my wee car again...!!