2000 Holden Vectra CD from Australia and New Zealand - Comments

16th May 2006, 06:52

Has there been any further developments with the resolution of this (speedometer, ABS, TC ....) problem?...

27th Apr 2008, 03:12

I have the same problems. Holden garage has done tests, but nothing comes up and it also cuts out at times!!

Would appreciate more feedback to compare.

4th May 2008, 22:37

Our car is currently getting a second hand ABS Controller so will advise if that fixes it. Our symptoms are EXACTLY the same. PS We already have a new Alternator and a bill for $1080 in labour (not including the labour on the ABS controller) - I also believe these Holden repairers have no idea what they are doing.

4th May 2008, 22:40

I got quotes for the ABS module NZ$4500 for new parts, $2500 for second hand, We are trying one found for $500 with a 6 month warranty. Fingers crossed.

5th May 2008, 20:18

Replaced the ABS module NZ$500 for new parts + $300 labour and it appears to have solved the problem. Will road test and re-post if it reoccurs (ie did not solve the problem).

1st Oct 2008, 22:08

I had the same problem, fixed it after replacing the gauge cluster.. Just bought a second hand one from the wreckers for $50 and installed myself.

It could be a number of problems, so I'd start at the cheapest and work your way up, unless of course you know for sure what it is.

14th Apr 2010, 20:35

I have also experienced the same speedo / ABS / TC fault; however the engine does not stop in my case. Auto electricians have advised that the fault is in the electronic controller of the ABS module, but have not yet had repaired.

I also have a shudder, which goes through the drive train at about 70 kph - both on acceleration and de-acceleration. It appears to be when the torque converter 'locks' and may be the converter locking, unlocking and then re-locking (or reverse in the case of de-acceleration) over a short period. The shudder can be quite strong, depending on how the vehicle is being driven at the time. Holden service have indicated that this is normal / common. Has anyone else experienced the same issue, and what if anything has been done to rectify?

My Vectra is a JS V6 2.5L May 2000 build.

16th Dec 2011, 15:53

I also experienced the problem of ABS control module for my Holden Vectra, where the problem is ABS, TC, engine check warning lights are on, and speedometer drops off, odometer and cruise not working when these come up. So my mechanic advised me to replace the ABS module by detecting the problem by computer scanning. He said it costs around AUD 450. I am looking for cheaper one from a wrecker.

Add another comment

Note: A Comments RSS Feed is available. New comments appear in the Members Area before the main site