2002 Isuzu Rodeo LS from North America - Comments

16th Feb 2005, 10:05

I have a just purchased a 2003 Rodeo with 9,000 miles on it in November of 2004, it is still under warranty, so I 'm not too upset, I have just had my first oil and filter change and at the end of January my battery went, I was still covered under the warranty for the new battery, but now my CD and radio are not working, even though it is also covered under the warranty, it is a nuisance that these minor problems continue to occur on a fairly new vehicle. please if anyone else is having these kinds of problems, can they send a response.

29th Jun 2006, 16:10

I bought my 02 Rodeo in November 02..It had a few problems the 6 CD changer jammed (twice) had to be replaced... and I am at 73K and now I am having problems with the gear selector... sometimes it does not correspond with the monitor in the dash... I have to turn off the engine and it will be OK for awhile and the go back to the same problem..other than this, it been OK... I would like to hear from those of you having the same problems especially with the auto transmission miltontfam3@aol.com.

9th Nov 2006, 06:38

Purchased 02 Rodeo LS new and at 28K miles had oil problems burning and gas milege dropped to 12mpg, now at 35K I have the check engine light on. I've kept up on all maintenance and fell this vehicle is not worth the money spent and would not recommend. I think it's time to look for new vehicle.

14th Oct 2007, 18:08

I am a owner of a new 02 rodeo. At 40K miles had transmission switch problem (lights up dash P, R,D, N etc) did not correspnd with gear number. At 50k same problem this time it was out of warranty and I had to pay $400. Now I have a check engine light on at 75K replace O2 sensor. Ultimately not real happy, time to look for another Make-Model and year.

10th Jul 2008, 02:56

To Milton: June 2006 comment regarding CD changer & gear not matching on dash & shift. I also had problems with CD changer which was replaced by dealer, but the problem has reocurred. My gear shift & dashboard started giving problems, not sure what causes this. I am looking for help on this one. The check trans light came on when I was driving. The dash was showing as parked. When I turn car on & off and it sits for a while, the problem seems to go away, but then reoccurs after again and again. Were you able to get any answers on this?? I have had my 2002 since 9/01. The dealership was sold, so all my warranties and promises went through the window with that one. I am no longer living in the state where I purchased the car, so that is another problem for getting answers. Looking for your help here!! reply to yvonneraeg@yahoo.com.

Thanks!

5th Sep 2008, 16:13

To Yvonne: Did you ever find an answer to your problem? I had the exact same problem and we have the same vehicle. The problem with mine was the inhibitor switch I believe. I only have 2 payments left and I just hope I can drive it for a while longer without problems. I have a 2002 Rodeo LS and have 75,0000 miles on it. So far, I've had the following problems:

Molding on driver side door replaced

Replaced 6-disc changer

Key stuck in ignition - had to get a screw replaced that had fallen out of steering wheel

Inhibitor switch replaced after transmission started shifting hard and gears switch wouldn't show correctly

Check engine light now on - need to get new oxygen sensor.

Good luck to everyone else out there with your Rodeo. It's been a fun ride, just a lot of problems I wish I had known about from the beginning. I'ts the first car I've kept through term and will be paid off in October, so I should feel grateful but just hope the problems don't keep coming. Any advice to other Rodeo owners is a great way to share things to be aware of, especially with Isuzu now out of the US market.

1st Apr 2009, 11:10

I had the 6-disc changer problem, and aome to find out it was because I played burned discs in it. They replaced it and I have not played a burned disc in it since, and have had no problems since.

19th Jul 2009, 00:31

Hello.

I've owned my 2002 Izuzu Rodeo for over 6 years now. I've had absolutely no problems at all until a week ago (July 2009).

1. My transmission slips/lurches from a parked position to 1st gear and 2nd gear.

2. My air conditioner only turns on when I'm on the freeway. It's been over 110 degrees in Vegas this week and I neeeeeed my A/C!

3. Sometimes at a stoplight when I take my foot off the brake, the car rolls backwards instead of automatically driving forward as it normally would.

I'm taking my car into the dealership. I hope they honor my 10yr/120,000 powertrain warranty that I paid $1500 for when I purchased my car.

29th Jul 2009, 19:27

I have a 2002 Isuzu Rodeo. Just had the engine replaced under the 10 Yr/100,000 mile warranty by the maker. When they were working on the engine they noticed the clutch was bad and replaced it (I paid for this). Now the shifter falls out of 1st and goes back into neutral. This can be dangerous if I am trying to get out onto a busy street. Anyone know what is causing this and "Will it cost a lot"? Going to the dealer next week to check it out.

12th Aug 2009, 19:19

I found out about what is wrong with my 2002 Isuzu Rodeo where if I put the shifter into first it will fall back into neutral. They told me it is the Hydraulic Pressure Gauge. There is not enough pressure in it to keep the shifter in gear. It is part of the powertrain, which is covered on the 120,000 mile warranty. Waiting for them to order a new part.

Although I have had a lot of problems with this Rodeo, the 120,000 mile warranty is really nice to have and they have honored their commitment so far.

22nd Aug 2009, 20:50

Oh man, I am so glad I didn't buy an Isuzu Rodeo back in '03. I see these reviews and it just makes me feel better about my decision. SO GLAD I stuck with my '96 Accord I had at the time. And so angry I sold it a year later! Ugh... bad decision.

4th Sep 2009, 17:18

I have a 2002 Isuzu Rodeo that has just over 111,000 miles on it. Only problems I have had unfortunately happened all after my warranties ran out.

1. Oxygen Sensor went bad - cost $350.00.

2. 6 disc changer kept jamming - $100.00 to get a new single disc changer from now closed Circuit City.

3. Radiator cracked and had to replace it - $200.00.

4. Now transmission is slipping and not sure about the cost yet.

There have been other minor things, but I have been able to live with it. Overall for the price I paid $22,000.00 seven years ago, not too bad, but it stinks this has all happened after my warranty ran out!! I would not get another Rodeo and would consider paying more for a used Honda or Toyota SUV model.