1996 Pontiac Bonneville SE from North America - Comments

21st Oct 2008, 08:44

I have a 1996 Bonneville SE with 195,000 miles and it runs great. Had to replace fuel fiter, CV joint, and tires. From there on basic maintenance and it runs great.

7th Nov 2008, 01:44

I have a '97 Bonneville SE that I bought in late '97 with about 20,000 miles on it. It now has 150,000 miles on it.

Ran fine until about 4 months ago when it started stalling out on me occasionally. Had to replace the intake manifold and EGR valve, stalled again. They replaced the MAF sensor. Stalled again. They replaced the fuel pump, fuel pressure regulator and radiator (found a crack).

It's now in the shop because the new fuel pressure regulator failed, but it was under GM warranty.

A year ago, the AC compressor went. Prior to that, changed the serpentine belt, water pump, battery cables.

The gas gage went kerflooey a long time ago. I'm not fixing it.

Water leaks into the car on rainy days.

And every once in a while, the trunk latch refuses to catch.

The car has several dents and scrapes, but I never fixed it because I kept thinking I'd buy a new car soon.

Unfortunately, this car has the best ride and most comfortable seats of any car I've ever driven, and I'm having a hard time parting with it. Even after all these repairs, I'm afraid to rely on it with winter coming, so I'm looking for a new car. Nothing comes close, certainly not any of the new GM's, and the imports don't excite me. This is the best car I have ever owned.

9th Jan 2009, 15:06

My `1996 Pontiac Bonneville does the oddest of things: In warm weather it will stall while in motion, or sitting. It dies, and I start it up again, and off we go again. I can actually put it in neutral, if I was going fast enough, and it will crank up again easily. I suspect fouling in the injectors or carburetor, and of course have been putting the cleaners for that problem in. Yet, during one bad and long winter, it went seven months without a problem. I have changed everything, plugs, wires, Manifold, and the usual maintenance items. Gas cleaners have no effect. I also suspect sludge in the gas tank. Curiously, it stalls while going up hill or down. Filling the tank decreases the problem. Help anyone?

17th Feb 2009, 17:52

I bought a 1996 Bonneville in 2003. I've put on tires, front brakes, starter, alternator, battery, and an intake manifold. It's a been a good car, knock on wood, I bought it with 90K miles for $4200 and it has 150K on it now. I hope it sees 200K.

The 3.8 litre motor is a good high mileage motor. It started as a Buick V8 and they changed it to a six back around the 70s. There's a known problem with the intake manifold on the 3.8 litre series II motor. They increased the motor's horsepower to 205. They also tried to lightened the motor and part of this was changing to a plastic intake manifold. This was a mistake, unless you're selling intake manifolds. The metal pipe to the EGR valve over time can melt the intake manifold which can will let antifreeze seep into a cylinder, that's where you hear of people's motor's freezing.

But you have to compare this to what else you can by. The Pontiac will be less than a four cylinder Camry or Accord, and they'll need new timing belts and the Bonneville will not.

13th Aug 2009, 12:09

I purchased my 1996 Bonneville SE, in 2003. It had 112,000 miles on it. For the first year it drove like a dream, with the exception of the faulty keyless remote. Then slowly but surely things started going wrong. The car alarm would go off for no apparent reason. When I put the windows down, sometimes I could not get them back up. And worst off all I went to start it one day, and KABOOM!!!... there goes the intake/manifold...

25th Jan 2010, 14:01

Well I can say now with facts that I too have had what I call routine maintenance tasks since hitting the 120,000 mark on my 1996 Bonneville SE, which I bought in Oct 1995 with 6 miles. Most I consider normal stuff like brake jobs, rotors, new radiator, new tire, new fuel pump, new batteries, alternator, alignments, oil changes every 3000 miles, service every 70,000 - 100,000, transmissions, new belts and tension pulley, new heater hoses and thermostat, new electric cooling fans, new spark plugs and wires etc.

The AC cooling tube and compressor kinda annoyed me somewhat, and THREE power steering pump and the one rack and pinion.

Anyways, recently replaced the pan gaskets and transmission pan gaskets.

But now face a some leaking antifreeze on top of the engine, anybody know what this part is?

A gentleman above called it a heater inlet pipe (cannot google this phrase). Well this is where it took me. I do believe it leaks more with the heater on.

But with all that, I feel the expense of my new Enclave per month, versus the total cost of the Bonneville so far with parts to maintain it. Well I still feel I am coming out ahead, and believe it has been a good purchase.

260,000 miles and going on 14 years at 28 to 30 gallons to the mile, noting it has done a lot of hwy miles, letting me travel and save on gas expense through these years.

Lets go green on TV, lord I was getting 30 mpg in 1996 with this full size car that rides fairly good still today LOL. Not a two seater and no comfort models of today's green cars.

My 2009 Enclave gets 20 MPG on a good day.

genalogy1@yahoo.com

26th Jan 2010, 17:49

Could be your upper intake manifold and gaskets or it could be your lower intake manifold gaskets, or your coolant elbow near the alternator.

BTW have you ever replaced the upper intake manifold or lower intake manifold. Both are a guarantee failure at some point with the upper manifold being more common and usually first. And 260,000 miles is nice; I'm at 163,000 on my 95 Buick.

13th Oct 2010, 23:12

I've heard a lot about problems with the 96 Bonneville SE, but why haven't I heard about the one problem that I know most are having with this car? THE TRANSMISSION; the check engine light comes on (which should be for the engine right?) and this car throws out this 1870 like it's candy on Halloween. The car would run fine, but in about a year will break down on you. Everyone I've taken it to says it needs to be rebuilt. I never had it rebuilt, because I'm scared that the same will happen again, and who wants to throw away 1500 to 2500 dollars, but I've replaced this transmission twice with a used one, and I've gotten the same code; this is ridiculous.

Thank you very much General Motors.

1st Aug 2011, 22:36

I have a 96 Pontiac and it still runs like a champ. The only things I've ever had problems with are very little. Still runs amazing with 210,000 miles on it.

21st Jul 2012, 11:57

I have a 1997 Mercury Villager, and face the same coolant leak problem. I removed the hose from the intake manifold going to the back of the thermostat housing. I took it to Auto zone and had it matched to a replacement hose. Total cost was just $8.34 for the hose. The replacement hose had to be cut to fit the 90 degree elbow, and new clamps were added; $4.24. The leak has been fixed.

8th Mar 2013, 12:17

Try the airflow sensor.

Add another comment

Note: A Comments RSS Feed is available. New comments appear in the Members Area before the main site