7th Oct 2005, 15:21

Rust under the dash!!! I work at a renault dealership and have never heard of this!! I even drive a clio 172 and mine is not rusty, while it sounds very petty now and may not get any worse for the rest of the cars life it would be worth asking if it could be cleaned up so you can at least see if it is getting any worse.

16th Feb 2008, 10:44


I used a diagnostic kit from work and I managed to clear the faults and put out the engine check light, the car was running OK until I touched the plug at the rear of the engine. My suggestion... IF you get any engine running problems, give it a good service and have a look at the engine loom plugs (top center at the rear of the engine bay) This may or may not fix the problem, but at least you will know you've given it a go...

25th Jun 2008, 20:32

I work in the motor trade, and you know what's up with it?


The car is getting damp.

31st Mar 2010, 03:15

Reading your comments I agree, I have rust all under the dashboard, and also water leaking in from everywhere. I have had my Clio 6 weeks. First problem the coil went, now I have water gushing in from everywhere. The Clio looks lovely from the outside, but look further; the problems everybody seems to be having I'm also experiencing. I'm spending a fortune getting this sorted out. Really regretting this car.

11th Jun 2010, 04:14

The problem of stalling at the lights happened to me this morning, just like several of you above. A faint noise also appears to come from under the bonnet in the 1 or 2 minutes preceding it.

I'm now finding myself perfecting the skill of keeping the revs going while I'm stationery to prevent it happening again.

I've no idea where to start in terms of the cause of the problem, as it looks as if you guys have various possibilities - hopefully a diagnostics machine can help me out.

Does anyone have any further updates on how they resolved this?




19th Oct 2010, 04:34

I bought a 2003 1.2 16v Renault Clio in May 2009.

After I had it almost 6 months the car wouldn't start one day. After checking it out, we realized the starter motor was jammed, we hit it a few thuds and the car started fine. We took apart the starter and cleaned and oiled it and it hasn't happened again since.

In the past week a slight shudder has started in the engine almost like a misfire, but the sparks are good so we are assuming it might be the plug leads.

Other than the above I love my Renault Clio, it's a dream to drive, looks great and I'd hate to part with it.