20th Apr 2010, 18:40

I bought my 2006 Impala LT brand new.

I have had the following issues:

Alternator replaced

P/S hose replaced (under warranty)

I have also had major issues with my transmission. When driving on 20 + minute rides (on highways) only, the Service traction control light and sometimes the Service Engine light comes on. I've taken the car in many times and finally the dealership said it's a mechanical issue where there is a mechanism in the camshaft that "sticks." They said it would be a ton of money (to replace) in labor, so I have passed on getting it fixed, since I have 80K miles on it. However, when this happens, my car shifts very hard. The problem will go away after the car is shut off and sits for 5-10 minutes.

Has anyone else heard of this?

10th May 2010, 22:17

I bought my 06 Impala used with 60,000 miles on it.

It's a LS with a 3.5 liter. As of right now it has about 100,000 miles on it.

Things I have replaced include :

1. Rotors - they were warped bad.

2. Passenger side rear trailing arm broke.

3. Power steering rack twice.

4. Power steering return hose "fell off" twice.

5. Tie rods.

I have the typical clunking when turning the steering wheel, and also a humming noise.

Once every so often the temp gauge will drop all the way down to cold and a message will pop up "Engine hot AC off" and my AC won't work. But it goes away.

If my gas tank is full, I forget to disable the traction control and I take off really fast, the front end will slip really bad and the message "Service Traction Control" will come on. So I just remember to disable when I drive it.

The sunvisors are broke and I'm not replacing them.

The positives include : It's a great looking car; I get a lot of compliments on the exterior. The interior is comfortable. I get around 30-33 Mpg highway.

I also got in a bad accident a couple years back, and I'm glad I was driving this car, because if I had my previous car I probably wouldn't be here typing this.

I have had problems with every brand of car I have ever bought. I'll never own a Honda or Dodge again because of "timing belts". I prefer a chain.

I plan on keeping my Impala because it saved my life.

12th May 2010, 08:36

WOW! I am amazed to see how many people have all these common problems my mom has with her vehicle. This is a '06 Chevy Impala with 68,000 miles on it and has a 3.5 L engine.

All these problems just arose sometime back in late '08 early '09.

The driver window screeches so bad when opening and closing, and this happens every so often.

Steering column is knocking with every right and left turn. Had the family mechanic take this steering column apart TWICE, and still could not find anything.

Have a problem with the transmission not wanting to get out of Park into Reverse when parked on a slight upward hill.

Check engine light turned on with no cause whatsoever; took it to the mechanic again and still nothing was wrong with it.

Heater takes forever to kick in early in the morning when trying to defrost the front windshield.

Don't even get me started on the sun visors... the dealership wanted to charge my mom $100.00 plus installation... you must be outside your d*** mind. This is obviously the manufacturer's problem, not the buyer, and I do believe this is a hazard because it did happen to me when driving; it just falls in your face, obstructing your view.

Just got a letter in mail last month from GM for a recall on '06 Impalas to have the intake line for the power steering to be changed, because the line can bust. Go figure, we are all having problems with the steering on this car, but yet they can't take blame for everything else that is wrong with this car. Maybe we should all put GM on blast, just like the world did to Toyota.

I would just hate to see this car cause any accidents due to poor manufacturing. If anyone has any information of how to get rid of these problems... PLEASE let me know debileigh5480@yahoo.com

17th May 2010, 08:10

2006 Chevy Impala 3.9L.

I am having a familiar issue with my rear doors as I have seen on here.

The rear doors are not opening, even though the locks go up and down.

I called a dealership this morning, and another gentleman is bringing in their car today for the same issue.

Anyone else, please post up if they know how to fix, or if this is an issue with yours.


You can email me at kenyonfan06@aol.com

26th Jun 2010, 13:24


We have a '06 Chevy Impala as well. Driving for 15 minutes or more, my traction control will come on and sometimes our engine light. I simply don't understand the madness, since the mechanic advised us to turn if off. It still comes on, and I just want to know how to fix this problem without breaking the bank? Please help, do we need to get this recalled for assistance?

8th Jul 2010, 22:22

Out of the blue, my 2006 Impala SS will not move forward in drive. Car will only move in reverse. Never any noise, problems or issues. Any ideas?

12th Jul 2010, 19:23

I have a 2006 Impala, 70,000 miles. I have never had problems till today. All at once the turnsignal/emergency flashers quit working, the hood open message showing even though it's shut, the trunk won't release and the remote star won't work.

Anybody know what's going on?

2nd Aug 2010, 14:01

I was just wondering if anyone out there has had a problem getting their 2006 Impala SS to shift out of park. This has happened to me, and I was told the wiring was damaged.

14th Aug 2010, 11:35

Did any one find the solution for the screeching windows yet? If yes, please email @ toomera@yahoo.com cos I have the same problem. The p/s hose is on recall right now in the dealers.

14th Aug 2010, 23:39

Bought my 2006 Impala one month ago with only 26k miles. So far I've had to deal with the annoying screech the driver's side window makes. I have to "Baby" the transmission at starts. I sometimes have an issue getting it out of Park, but I must admit, the car is on a very "slight" angle.

And now the biggest issue of all, one which I haven't seen anyone post yet. When the A/C is on for awhile on hot days, the passenger side floor is soaking wet! When you turn to the left, I can hear the water behind the dash moving, & then I can see it coming to the floor. Once the A/C is off, it doesn't do it. Not exactly sure what that is. I've owned two Lumina's & got well over 200k miles on both. I take care of my cars, but quite honestly, this is the worst Chevy I've ever had.

22nd Aug 2010, 08:20

I bought an 2006 Impala SS 6 months ago. I have a lot of the other issues everyone else has, PLUS the dash and gauges go dead driving down the road, and then the traction control and anti-lock brakes monitor comes on. The doors start locking and unlocking, and the transmission starts severely shifting hard. If you shut it off and restart it, then the gas pedal doesn't work, so the car will not move. Then I have to disconnect the battery to clear the computer. Hook the battery back up, and the car will be fine for maybe a week, or as long as a month. I pride myself for never buying a foreign car in the 30+ years I have been driving, but now re-evaluating that position after this car...