2002 Citroen C3 Exclusive from UK and Ireland - Comments

13th Mar 2008, 11:37

Boy am I glad I found this site, I test drove a 2004 1.1LX C3 this morning, was seriously considering purchasing it, until I read the comments here! So it appears Citroen are still building poor quality cars, oh well, I'm going to stick with the good old trusted 2000 year Mondeo. Funny thing is, the garage selling the C3 only offered me a grand for my car, what a cheek, by the comments here, he should have been giving me a grand to take the C3 away!

Thanks for the heads up people.

29th Apr 2008, 07:34

I had the Citroen 2003 C3 SX - it broke down continuously, engine losing power which probably happened every couple weeks. All I can say is - don't touch them with a barge pole. It was a nightmare. Citroen couldnt fix it and when they did, it happened all over again. Said they couldnt find anything wrong with it. In the end they thought it might be electrical - with a result after spending hundreds I got rid of it and bought a new Ford.

Beware is all I can say.

20th Jul 2008, 16:09

Can anybody help. My C3 warning light come on, says auto fault, then goes out. The car runs OK, but this happens about 3/4 times a day.

8th Oct 2008, 17:33

My citron c3 petrol O2 model has managment light keep comming on engine stalls and cutting out changed injector 4 and wiring can any body help.

30th Oct 2008, 17:27

Just booked my C3 into the garage again - had it 3 months and it has just started cutting out on me - very dangerous and Citroen cannot find the fault - I'm selling mine tomorrow! Warranty runs out in 3 months and I'm not being stuck with the bills!

6th Jan 2009, 07:53

C3, well we have a car which doesn't work due to the Eco Mode, which is supposed to save power, won't let the car start.

Then a couple of days later it starts and runs fine, then it happens again.

We have asked Citroen to turn this feature off in the ECU, which we know on good authority can be done, but they keep saying they can't, and we need to replace the computer for £875!

My advice, buy Asian, where they still have a passion for making good cars, anything made in Europe or America is built by accountants and bound to go wrong.

10th Jan 2010, 07:21

Yes, I agree with comments on the Citroen C3; it's a pile of rubbish!

20th Mar 2010, 14:41

Hi, I have a 54 plate Citroen C3 automatic. Have done 45000 on the clock.

I can be driving along quite nicely, then a bleep sounds, snow and sport mode flashes, then I go into limp mode, then I have to pull over, turn the engine off and restart. Then the car is perfect till the next time it's parked up, and I go out and the same thing happens within 10 minutes of driving. Very dangerous when going round roundabouts or dual carriage ways.

Had a diagnostic test; was told it was the solenoid 1 and evs1 garage replaced transmission fluid, but 4 miles down the road it happened again. Now been told I need a new gear box costing £1600.

Worst car I have ever had. Have only done 2000 miles in it since I got it. As the car is still on finance, I'm stuck with paying that every month, and now looking at having to have a new gear box. Never again would I buy a Citroen.

20th Apr 2010, 06:42

Hi, have had a Citroen C3 for six years.

Second year, injectors went, brought it to a Citroen garage, cost 350 euros to fix.

Last week, went again, got an injector rack for 50 euros in a car dismantlers. Mechanic had it fixed in 15 minutes, cost 50 euros.

7th Nov 2010, 16:51

Was driving my Citroen today, and all of a sudden my steering stiffened up, and at the same time the speedo dropped to 0mph, even though I was doing about 30mph at the time. Need to take it to the garage; was just wondering if anyone else has had a similar problem at all, and if so, what was wrong?

Cheers!!

6th Dec 2010, 12:54

Hello! I have had my C3 for nearly a year, had nearly 80,000 on the clock, now 120,000. faultless until today! Repeatedly the engine management light comes on, car stutters, and limits the car to 3000 RPM.

Turn it off, open the bonnet, it all seems fine after that! Some mechanics friends say it could be the window washer jets as they are not sealed to the bonnet, and water then leaks onto the injectors.

We'll see!

I'll keep you posted.

21st Jan 2013, 09:31

Hi, just wondering if you have ever found out what the problem was, as mine is doing the same thing. Would really appreciate a little bit of help.

Thanks.

11th Oct 2013, 16:35

BEEN TO THE REST, NOW TRY THE BEST!!!

King's 5 Star Vehicle Services

Servicing & Repairs

20-22 Esk Street

Bootle

Liverpool

L20 8JT

If they can't fix it, then no one can. I am posting this as I took my 2004 C3 there, and was so impressed with their work and the price. My C3 was giving me a headache; it would cut out and go into Eco mode. The battery light would flash and would not start. I took it to the dealers; they could not fix it. I took it to an auto electrician; they also could not find the fault because Eco mode turns off the diagnostic plug that reads the ECU. Dave at 5 Star fixed my car within 6 hours; the fault was broken wires in the wiring loom. That was 12 months ago; never had the same problem again. I now use this garage all the time for services etc. I have noticed loads of reviews with the same fault. Won't hurt to try them. Dave 07546432843.

Add another comment

Note: A Comments RSS Feed is available. New comments appear in the Members Area before the main site