1st May 2001, 03:40

Write Ford. Your complaint is common and the issue needs to be resolved. I am going to write them as well, as soon as I figure out what region (s) these complaints are from.

23rd Jul 2001, 11:48

MY 1999 FORD ESCORT SE SPORT makes the same knocking sound when I turn.

The windows leak because the door seal insists on popping out all the time (hmmmm you think they would have used an adhesive to hold it in place).

My air conditioning now makes a buzzing noise every 7 seconds.

Ever since I bought it brand new, the air conditioning wreaks when it is turned on. So much that I have to drive with my head out the window for at least 1-2 minutes.

I have to say that I am NOT impressed. This is my first American car since I've owned 9 Hondas.

I think I'm going back to what I know and trust.

18th Aug 2001, 18:09

I have a 98 ZX2 and I have been having problems with the dealership. More than anything the car is starting to backfire and stalls out when at red lights, also the vent closes when you turn the A/C on high. But other than that, I love my car.

2nd Mar 2002, 13:03

Can't believe you guys have been having so many problems, my ZX2 is at 75,000 miles, and hasn't had a single problem (other than needed heat shield adjusted which cost maybe $50)..

Hope you guys got those problems fixed under warranty..

13th Jun 2002, 10:55

I own a 2001 ford zx2 and I have had nothing but transmission problems. When I first got the car it would not go into reverse it felt like the e-brake was on, and now it slips when driving and nobody can find anything wrong with it.

27th Jul 2002, 19:04

My daughter owns a 98 zx2 and loves it. Recently the air conditioning quit working. My husband (a mechanic) took it to a friend who put it on the computer. Found out it was the Constant Control Relay (Module?). Anyway, we have tried 4 of these parts and the problem is the air conditioning will go on, but a few seconds later kicks off. He can bypass this by unplugging the one wire and the air conditioning will work, but the motor fan runs constantly. We were told that there is a problem with this part and not all parts will work with all zx2s, but it's like finding a needle in a haystack finding the right part. Were still looking.

5th Dec 2002, 10:31

98 zx2 here, 85k and very happy. Just a small leak in the radiator recently. Don't have any issues as those above.

10th Feb 2003, 18:26

We purchased a 2001 Zx2 for my daughter for graduation and are having problems with the fuel tank. It won't take more than a gallon of gas before shutting off and spewing gas everywhere. Anyone else have this problem? The dealer put all new parts in and say that the only other thing they know to do is to put a whole new gas tank in it. It has less than 5,000 miles on it.

8th Jun 2003, 00:20

I've had my 99 Escort SE Sport for a little over a year now, the only problem I've had is the AC compressor went out, and I had that replaced.

I've upgraded my headlights to HIDs, put in a little $750 sound system, replaced and upgraded little things all over it to make it more enjoyable, and it runs great.

In fact, after all that stuff I've done to it, I'm getting around 29/37 city/highway MPG.

27th Oct 2003, 08:35

October 27, 2003.

I just purchased a 1999 Ford Escort ZX2, I had to replace my battery which is normal. But the Service Engine Light came on and I had the vehicle serviced the light is still on. The coolant for some reason is coming out of it's coolant container and the air conditioning system gets cool and then it blows warm air. This morning it was pretty cold outside so I turned the heater on "no heat." I turned the heater off with the dials still on heat and hot air was blowing on the floor. I noticed the temperature needle goes from the center to cold, now this is scary. I really like this car and I really don't want these little problems, this is the first car note I've had in 15 years and my old car which is a Chevrolet runs circles around this car. Glad I didn't get rid of my 1987 Caprice Classic.

15th Sep 2004, 09:31


I purchased my daughter at 1999 ZX2 over 2 years ago. Recently when you turn the air conditioner on with fresh air, you can smell gas. Anyone have any ideas what this is?

Please email me at


Thanks a bunch,


15th Dec 2004, 06:16

Hi, I don't know what all the complaining is about. The only thing wrong with my 98 is the window, it leaks, go figure. Good luck with your problems.

12th Nov 2010, 16:11

I got s 1999 Ford ZX2. It's shaking all the time, and the rpm is below the 1, but when I turn the steering wheel, the rpm goes down even more, and the car shuts off. I did the computer test and it says pass. I've change idler control valve, powers pressure sensor, O2 sensor, mass air flow sensor, and nothing...

20th Nov 2010, 17:20

I have a 2001 Ford Escort ZX2, and I received it from my aunt as a gift, because she no longer drives, and the car was just sitting in her driveway. Very good condition, and only a few things needed replaced, but my Dad fixed everything he could find, and it ran perfect for him.

I only have my temps, so I drive with my Mom, and after she dropped me off at work, she told me about the car stalling at a red light, and I didn't know anything about it, and it never happened to my Dad.

That was yesterday, and now today I was driving it, and when I went to turn into a parking lot, the car stalled... twice. Haha I eventually got it running, and got out of there, but still scared me because I was almost stuck in the incoming lane when it stalled.

I was on this website right before I left on that trip, and noticed other people have the same stalling problem. I don't even know what it may be, but I hope we can figure it out because I love the car and it's in nice condition (which I got for free), and I would hate to spend a couple grand on another car, just because of this problem.

19th Jun 2014, 18:51

More than likely someone has shoved something into the gas tank, or tried and it is lodged in the filler neck of the gas tank. Or your gauge is wrong and you keep trying to fill up an already full tank of gas. I'm sure this is an old thread or question, but it might help someone out later.

I own a 2002 ZX2, but bought it 2014 (this year), so yeah I have good chunk of change and a trunk full of car parts (about $1600 worth), and a lot of new everything on already. But from what I can tell, before I put work into it, mine was in pretty bad shape, and still ran like a little beast.

It has a noisy drive train (mine's manual), but I'm hoping it's mainly the clutch, which I have the replacement in the trunk, but I'm trying to use this one up, as it's still good. Doing the rear main seals, so figured when I do it, I might as well throw a new clutch and flywheel in while it's apart, but anyways, it's a good car in my book.

11th Oct 2014, 17:01

It sounds like the noise you hear is simply the compressor short cycling due to low charge - put some gauges on it and charge to factory specs.