2001 Mazda Millenia from North America - Comments

17th Dec 2008, 21:09

I own a 1999 Mazda Millenia S. This car is horrible. I recommend that you never buy a Mazda.

The check engine light keeps coming on. I took it to a mechanic and he said I needed a new timing belt, a new turbo pulley and a new catalyst.

4th Jan 2009, 12:03

Loved it when I bought it a month ago... was a cherry. Hate it now, it's a lemon. Run away fast.

15th Jan 2009, 23:22

I own a 2001 Mazda Millenia P (not the supercharged). I have 143,000 miles and have had very little in the way of major repairs.

I change the oil every 3000 miles. I have small oil leaks from various gaskets, but recently I am having the violent vibration and shaking from the engine when my foot is on the gas above 60 mph. As soon as I take my foot off the gas the shaking stops. It sounds like a bunch of owners have had this issue. What is it?

Based upon the prior posts, I might be better off just getting rid of the car before I get into all those expensive repairs, but I do love this car.

Please send help email to fischsite@bellsouth.net

27th Jan 2009, 22:09

Bought my 2001 Millenia P (non-Miller) new in Aug 01 and have 95k miles. Got it for $20k plus sales tax as they were being discontinued. No major problems-

Hinged lid to storage on driver's door broke when the car was fairly new. Dealer replaced it under warranty. Now it's starting to come loose again.

O2 sensor replaced early under warranty. Check engine light came on again at 70k miles, and got that fixed (I think it was in the exhaust manifold) and got the 60k service package (timing belt and lots of other stuff) for $1,300. That included a hydraulic pulley for the timing belt ($250) and a waterpump.

Check engine light has just come on again, and the auto-tilt in the steering wheel just quit recently.

A couple of pieces of interior trim have come loose.

I noticed a CV boot was torn several thousand miles ago. I'll replace that myself eventually. I was looking for a repair manual online to do that when I came across this forum.

Love the car, it's still in great shape, but after reading this thread, I'm considering moving on.

Note to people who say their trunk release doesn't work - make sure the valet switch isn't activated in the glove box.

2nd Feb 2009, 18:36

Like everyone else I have experienced problems with the Mazda Milli S series, within the last two months it has been in the shop 5 times and the problems still not have been fixed. From the timing belts to the vacuum hoses to the radiator etc... this is an AWFUL car!!! Almost $4000 in maintenance.

1st Mar 2009, 10:10

We have owned a 2001 Millenia since 2002. We love the car. We bought it used with 28,000 miles on it and it currently has 209,000.

Yes, the check engine light has been on for maybe 4 years, it's a common problem with this car. We don't worry about it.

We have had the timing belt replaced, we have had the O2 sensor replaced, we have has the steering column replaced, and other things. But, it has never given us a lot of problems.

We have had the gas smell before, and now the transmission is slipping, but we have driven this car into the ground. We're hoping to fix the transmission issue and keep the miles ticking, but if it doesn't work out - it was a great run!

I think a lot of negative comments about this car are from people who may have bought the car from a shady dealer. Shady dealers = shady cars.

11th Mar 2009, 22:56

I have a 2001 Mazda Millenia with 56,000 miles on it. Never had any problems mechanical problems. Had to change control arms and suspension boots the other day, but that was covered by Mazda's extended warranty for these vehicles. The warranty costs $450 for 5 years with a $200 deductible.

I had a 1995 Millenia prior to this one.

I had the O2 sensor problem like everyone else is talking about. That is not because of bad sensors, it's because of a bad battery sending bad codes to the computer. Try changing your batteries and see what happens; that should solve majority of the problems, even the traction control.

16th Mar 2009, 14:11

I purchased a 2001 Millenia S on March 14, 2009. Traded a 1995 BMW 525i with major problems. I'm at the dealership now getting an oil change, duplicate key and touch up paint. I'm hoping to not have any of the problems I've read about on this site. So far it drives great - but it had only been a few days.

20th Mar 2009, 07:23

I have a 2002 Mazda Millenia S with 89,312 miles. The airbag light began to flash on/off around January 2009 for about 2 -3 weeks. It stopped flashing for about a month. Now it is flashing on/off again. I'm going to have a diagnostic test performed; however, does anyone have any advice on what could be causing the problem?

In addition, I sometimes experience a loss of power in the windows and radio (sound is off but radio is still on) for about 1 minute; then both will come back on. Any thoughts on this item as well and what is probably the cause?

Thanks.

20th Mar 2009, 16:54

I own a 2001 Millenia S for 2 years now, had 30k miles, now at 78k.

Only thing I had replaced so far was just both CV axles, other than that, full synthetic oil with K&N filter every 10k miles, runs like a champ and only now has shift solenoid problem, which is either the solenoid or the transmission, and just fixed my vacuum hose leak under the throttle body, love the car, looks good and has the kick for passing and launching when needed, and enough to compete with Lexus luxury.

This is my 2nd Millenia S, had a 2000 before this with 40k miles and sold it at 60k as it started giving me more problems with engine smoking and loss of power and O2 sensors, cats, coils. You name it, I changed it, including the supercharger, but I still loved the car enough to buy another one, and I like the styling more of the 2001-2002.

6th Apr 2009, 16:00

I have a @001 Mazda Millenia S with the Miller motor... It has 83,000 miles. It just started to have e A rotten smell inside the car... like an animal crawled up inside and died.

Moldy mildew kind of rotten food smell... it doesn't go away.

My daughter use to turn the heater up to 90... I told her not to turn it higher than 77... Do you think that could have something to do with it???

Car runs perfect... except for the smell! Anyone know what it is??? HELP!

22nd Apr 2009, 03:22

I am in desperate need of some help. I have a 2001 Mazda Millenia S with 96k miles on it. My problems are listed below:

1. Whenever it rains, IF I can get the car started, the idle is rough (I found two hoses to a broken 'T' connector and connected two, looking for the third)

2. Whether from a standing start or already in motion, whenever I press the accelerator, there is hesitation and then little acceleration afterwards, followed by better acceleration later.

3. Looking at previous posts, I also have the flashing airbag light that started recently.

Please forward all advise to supranyc@aol.com. Thanks in advance.