1999 Pontiac Grand Am SE from Japan - Comments

10th Nov 2009, 00:27

I got a 99 Grand Am. Owned it for 8 months, on the third motor. This time I rebuilt the motor, but now my ABS and trac off light are on. I cannot figure out anything about the trac system, and I drove it a week and all my warning lights came on.

The alternator went out, changed that, but still the ABS and trac off light is on, and for the guy with the dead battery, take the negative terminal off and put a test light to it and the post on battery. If it lights up, start pulling fuses till it goes out, then check what the fuse goes to.

21st Jan 2010, 19:26

Hey what's up? Grand Am owner, I also have a Pontiac Grand Am SE 1999 with a V6 3400 engine in white, and man I love this car, but it also kills my pocket LOL.

I put in about 1000 dollars in it already in parts. All the parts I put in I did by myself...

The things I have done so far were change the radiator, upper radiator hose, but first I flushed all the old antifreeze out and pressure washed the coolant reservoir. After that, I gave it a full tune up, changef the front brakes and adjusted the rear ones. I also replaced the front driver's side wheel hub bearing because it was making a humming noise, replaced lower ball joint, tie rod end, tie rod and stabilizer. But now I need to do the same for the other side in order for my ABS and trac control to work.

Beside that, the only thing to do is change all struts and maybe the springs too. I also needed to change the blower resistor for the heater, because it works only on high speed, no low speed.

For a 1999, I think I got a good deal for it. I only paid $1400 for it with only 79,000 miles on the engine and body. It's always good to get the repair book and read through it carefully. Good luck to you and God bless.

27th Mar 2010, 18:30

I have a 97 Grand Am SE too, which I love. I have had no major problems until now. I have owned it for 13 yrs now, and put over hundred thousand km. I keep the car well maintained.

My problem is the my dashboard rpm gauge, gas gauge, speedo and tach are now no longer working, and now warning lights are on in the car and I have no idea why? Can someone give me an idea what is going on with the car?

29th Apr 2010, 19:36

Own a 99 Grand Am SE. ABS & trac off lights come on then go off when I restart the car, now battery light is coming on and going off when I accelerate. Having the alternator replaced soon.

13th May 2010, 19:59

99 Grand Am GT.

When driving down the road, it will suddenly lose power and comes right back. I just put new alternator on 200 miles ago. Took it to a repair shop; they said the fuel pump was bad. Fixed it.

Last week had new starter put in it. All these repairs have been done in less than two weeks.

Battery is a month old. The car still does the same thing.

I know about the power steering noise. The rack has a leak.

Blower only works on 3 or higher.

Radio acts as if it's on crack, but still works.

I'm changing brakes every 4 to 5 months, thank god for the Auto Zone lifetime warranty.

The car still dies suddenly when driving down the road; usually comes right back. Sometimes I have to put in neutral and turn the key. Also sometimes don't want to start. Always cranks good, but just won't start. Other times it will start and then die right away.

I have put a lot of money in this car in the last month. Can't keep doing it. It's bleeding me dry. Does anyone have any idea what is wrong? Please let me know. email:fosnow31@yahoo.com

Thank you.

26th Jul 2010, 17:46

I have a 1999 Pontiac Grand AM SE.

I am having electrical problems. I parked it after work, went out the next day to go to work, the car started up, and quit. It did this continuously - no codes would come up with various code readers.

Thinking it was a fuel issue, I replaced the fuel pump, fuel filter, and fuel regulator to no avail - of course the starter burned out with all the trying to start the car, so new starter. My son also replaced ignition, to no avail.

If anyone has any idea what the problem could be, please contact me, Nancy at Moons46@aol.com

4th Aug 2010, 23:50

I have a 99 Grand Am that I have had for almost a year now...

Probably about 4 months after getting it, the alternator goes bad and we replaced it.

Then about 8 months later, the battery light comes on again. We changed the alternator because it said it was bad, then not even two minutes after putting the new one in, it goes bad again. So we exchanged it for another one, and it lasts 12 days. So we thought it was just bad product, and went somewhere else to get a new one, and it last only 2 hours.

We went to Ernst to get a brand new one, and a battery too.. we put it in today and it ran fine, and then after coming out from eating supper, the battery light comes back on...

We have no idea what is wrong with it, and it is my only car and I need it for work, so if anyone has any idea what possibly could be wrong with the car, please let me know at taradawn20@gmail.com

It would be greatly appreciated.

11th Dec 2010, 00:59

I own a 1999 Grand AM SE. I bought the car in 2005 with 50,000 miles on it. Now in 2010 and at 170,000 miles, I am having problems.

I have replace maintenance items such as numerous brakes and rotors, window regulators.

My car just died recently. I think it is the alternator, the battery is completely dead. It will not start, even with jumper cables. I am getting a new battery and new alternator.

Now I have replace twice the intake manifold gasket (cost about $1,000 each time). It needs it again (any suggestions?).

Other on going problems are:

The security light keeps turning on, I have to wait 10 minutes to start the car. (any suggestions?)

The other is the 4 way flashers/ turn signal clicking noise.

I have replace the circuit board couple of times, but the noise comes back weeks later (any suggestion?)

You email me you suggestions to floridamtbiker99@gmail.com (No, I cannot afford to buy another car)

Thank you.

Dan.

23rd Mar 2011, 10:21

Hi I also own a 99 Grand Am.

For all the people out there with the same car who have the ABS light or trac off light, or even just the brake light that is on, you should have someone that knows what they are doing check your ABS module. Where they are placed above your passengers wheel well, a lot of sand and salt get in there and just ruin it and make those lights go on all the time. But it is a 900 dollar part from the dealer, so if anyone knows how to turn off those lights I'd appreciate it.