2005 Chevrolet Equinox from North America - Comments

28th Nov 2005, 13:15

So you are dismissing this vehicle just because of one rattle? You wouldn't happen to be an import lover would you? Funny mine is just fine. I don't have an issue with the interior quality. I do have to agree though that it would be nice if it got a little bit better mileage. Of course don't forget the fuel tank is a bit on the small side making it seem like it uses more gas than it really does. Overall it does everything I want it to do plus work well in Wisconsin snow.

27th Sep 2006, 17:41

I have a 2005 Equinox and the back rattles once you reach 35 miles per hour. What should I do?

16th Jan 2007, 14:56

I have an '06 equinox LT AWD!! I paid 30,000 for mine and I wish I wouldn't had traded in my scion tc for this junk. My car had been in the shop at least 5 times the first year and for some major problems. I def. have the rattling in my car, but, it's the least of my problems with this car!!!

30th Jan 2007, 10:42

My husband and I have a 2005 Equinox, and we are very disappointed. Has less than 33,000 miles on it, but yet it has been in the shop 6 times in the last year due noises in the right front wheel, a rattle in the drivers rear, engine light comes on for no reason. And of course the dealer we bought from, is stumped. Chevrolet Dealership. Thank god it has been under Dealer warranty, but that expires next week. It is going in tomorrow 02-01-07 for more noises, but the biggie has been over the last week, now it won't start, takes now at least 7 tries before it will start. Has stranded me more times than I can remember!

Thank God we are selling it next week once it come home from the shop.

15th Apr 2007, 17:28

We bought a 2005 Equinox new and it now has 27K miles. We like the vehicle overall, but we also are having starting problems that GM is not sure how to fix.

9th May 2007, 15:31

My wife and I purchased a 2005 Equinox in July of 05. We have had it back to the dealer 6 times for front brake problems and it is in now for the 7th time. The pads have been replaced twice, the rotors turned twice and now the dealership is replacing the pads and rotors. The magnetic steering has rattled since the day we bought it and GM says there is nothing they can do about it. Would I purchase another one, no way. As a matter of fact, once it is out of the shop, it is history.

21st Jun 2007, 19:14

I just wanted to comment on my 2005 Equinox LT. The service department manager should know me personally by now. After having my vehicle less than 6 months, I had to replace my brakes.

I have the rattling noise and it is so irritating. If I hit any bump, dip, or crevice in the street...jingle, jingle, jingle.

For some reason, unknown to me and THE DEALER, ever so often my truck won't start. It sounds like it wants to turn, but it won't. After I attempt to crank 2 or 3 times it goes ahead and starts. The most was 4 attempts and then a crank.

Watch out for your front struts. I just had to have my driver's side replaced.

When turning my steering wheel I hear some grinding noise, what is this and how do I explain it to repairman?

I noticed that my driver's side window started going a little slow then it started popping out of place a little and it wouldn't line up. Well this morning I had to have some part, that all of a sudden warped, replaced on the window. It now goes up and down just fine, but for how long!?

I thought that this was the perfect little truck for me, but I must say that I am do disappointed. I love Chevy's, but not this Equinox!!

1st Jul 2007, 13:52

I bought a new 'o7 Equinox LS FWD in February and with 8000 miles on it, its been in the shop twice now because of engine faltering. When the engine is started and then put into gear it just sputters along for a while until the engine finally wakes up or warms up to go. The dealer says they have been in contact with GM, but don't know what to do to fix it. He suggested starting it up and wait about a minute before putting it in gear. (right!)

I was getting 22.7 m/g until they worked on it last time and now I'm getting 19.5. I fore see a lot of problems with this car and I wish I had bought the Honda I was looking at. Its back to the dealer again tomorrow.

5th Jul 2007, 16:52

About to finish my second year on a three year lease on our Chevy Equinox. My wife loves it, she's the primary driver, I'm disappointed in the gas mileage and limited rear visibility. Overall we have no major complaints, but there is one strange occurrence.

When the vehicle is cold, there is an odd thumping noise from under the car in the rear. It's happens enough to notice, but not with any constant frequency. Haven't taken it back to the dealer, because there has been no need for a trip to the dealer for anything else.

Any ideas?

9th Jul 2007, 11:54

I have the same odd noise that the last person commented on however I hadn't even narrowed it to only when it is cold. It is the most random, two-beat "cla-clunk" and that is it. As it is the least of my problems with this car, I've been ignoring it.

My brakes have also been worked on and are completely a mess again. It is to the point of being unsafe when I have to make a hard stop at faster speeds.

I also thought this was the perfect vehicle and am beyond disappointed. I plan to trade it in next month.

11th Jul 2007, 12:35

The engines in these cars are made in china and the transmissions are made in japan. Don't you people read the stickers? As soon as I read the motor was made in china I ran from the car.

19th Jul 2007, 22:41

I bought my 2005 Chevy Equinox in May of 2005. I am the sole driver of the vehicle. After it was purchased brand new, the first week I noticed strange shifting in the transmission at about 40 mph. I was told to bring it in and they would reset the computer. This did not help. Then there was a recall on this matter and I was told they would fix it. It still does the same thing to this day.

That was one problem, on top of that, the paint wears off on the number keys on the radio (that's been replaced twice), the drivers side and passengers side windows shutter when going down (after it rains), it has been lubricated, then window replaced and as of yesterday, lubricated again!

The brakes make a very bad noise when backing up. They've replaced the brake pads, rotors, etc. It still does it.

When trying to start the vehicle, it will continuously cut off. It took me 4 tries the other day, and then it finally started.

The driver and passenger side vanity mirror tops have both broke. I took it in at the beginning of the week for many of the same issues, and was told that it wasn't doing it while they had it.

They even had the service manager drive it home, and I knew for sure he would experience the same problems I have, but he didn't.

I have 35,300 miles on it and only have 700 miles left on my warranty.

I've been told that they will not drop me after the warranty, if it still has the same issues.

My whole thing is, FIX the problems it's having and I wouldn't have to bring it in!!!

I'm a very unhappy owner of the 2005 Chevy Equinox!