2001 Hyundai XG300 from North America - Comments

28th Jun 2009, 07:49

I have an XG 360 and 6 weeks ago all the dash lights and A/C started flickering on and off. I had it checked and was told it was the battery. Bought new battery drove for two days and the same thing happened again. Then was told it's the alternator. Had brand new alternator installed. Have driven perfectly for 6 weeks. Yesterday I turned on the A/C for the very first time and the same thing has happened all over again. Now I have brand new battery and alternator, but the dash started flickering and it went out again. Anyone else ever had this problem. Please help!

12th Sep 2009, 13:52

Hi all.

I have a 2001 Hyundai 300XG L series, and it has a 140k miles on it.

I love it, though I have replaced the tires, battery, alternator and blower motor. My local Hyundai dealer is awesome and I can get after market parts from the local auto parts shops.

I also have the haunted radio, slight leak in front windows and some cracks in the leather, but I must say that it is the best car I have ever driven.

Right now my only issues are a bit of rust and the need for new brake pads. For the money though it has a lot of cool features including the side airbags, which is very important to me as I have a child. It's fast, slick looking and everyone thinks it's a Sonata LOL.

I highly recommend a Hyundai, and my next car will be one!!

Jackie S. New Hampshire.

9th Oct 2009, 18:38

Bought one few weeks ago - unplanned - because of looks, dirt cheap, features and almost immaculate condition with private plate '2000' model, 48000mls. Fingers crossed things are working.

Still cannot understand whats the tab for on the bottom far right of the ACC panel (icon of man sitting with air blowing and a inverted L in front). Usually the blower direction is changed by Mode button. The remote key is a bit quirky, and strangely unlike other cars, there is no blinking light when alarm/immobiliser is on. BTW, can you get extended warranty on this car - mine is around 48000+ and W-2000 model and has a 1 year warranty from Marshall Peterborough. Some advice would be appreciated.

M. Cambridge.

10th Feb 2010, 14:51

I have owned this car for about 6 months now.

The only problem I have is the TCS light is always on.

Has anyone else had this problem?

20th Apr 2010, 10:46

Brought a Hyundai XG 300 new in 2001, great car in the past, now plenty of problems.

Engine light on and off periodically, found out online that it is the Mass Airflow MAF sensor needs to be replaced.

Radio on and off when it feels like it, CD works when it wants to.

Also now experiencing squeaking like that of pig from under the left wheel fender, and from the back of the trunk. Air bag light on, found out that it is a recall issue, so taking it to the dealer for adjustment free of charge.

6th Jun 2010, 22:46

I purchased XG new in 2001, have had numerous problems with CEL. Dealer always finds airflow sensor 3 times, EGR valve 3 times, or some combination of the two. Also have had trouble 2 times and today a 3rd with the transmission suddenly downshifting and getting stuck in 2nd gear. A faulty speed sensor has been blamed in the past, pretty sure I am in for a third. Our XG300 only has 70K miles on, and for the most part we have enjoyed driving it, but I am losing patience.

13th Dec 2011, 16:25

I live in England, and I have a 2002 Hyundai XG30. My problem is the drive light goes out and will not come back on when I change to manual gear change, then back over to auto gear change.

Any ideas?? Thanks.

Can anyone help with an answer please contact me at blackarrow37@virginmedia.com

7th Aug 2012, 21:44

Did you find out what the problem was with the dash lights going out? Did your running lights also go out?

27th Mar 2013, 05:37

The water pump is driven by the timing belt. If your water pump bearing fails, it can cause your timing belt to break. When the timing belt covers are off and the water pump is staring at you in the face, I guess it's the smart thing to replace it then, because if your timing belt fails, the cylinder head/s would have to be removed as it would bend the valves, which would cost $2000+ to fix. Any good mechanic would only recommending replacing the water pump while there doing your timing belt.

21st Aug 2013, 19:24

I purchased an XG new in 2001, have had numerous problems with CEL.

I purchased a used XG 2000 Hyundai Grandeur. It has done 195ks. Now I am having problem with this CEL that keeps coming on. Took it to the workshop and they replaced the thermo fan (L/H), but that didn't help. I took it back and was just told that they are checking the harnesses and cooling temp sensor.

Please help me as I've spent lot already.

Add another comment

Note: A Comments RSS Feed is available. New comments appear in the Members Area before the main site