16th Apr 2015, 14:28

It could be a faulty ground connection. There are some points in the car where a wire is connected to the car's body. You could have those points checked.

Or you can check if your battery is still in good shape.

10th May 2015, 12:21

I have Renault Megane Dynamic 1.6L. Suddenly the speedometer is showing only zero. Even when I accelerate whilst driving, it does not go up or show any speed.

Please advise me how can I resolve this problem myself?

12th May 2015, 08:53

It looks like your speed sensor is gone.

22nd Jun 2015, 15:57

Hi, I have a Megane 1.6 Dynamique. It has fuel, but the fuel light stays on. Any ideas please? Many thanks... Chris.

24th Aug 2015, 23:18


I've had a problem with my wipers working on and off on my 2004 Renault Scenic DCI Dynamique. It's not coming on at all now, and I wondered if anyone knows of some sort of manual switch that can be applied, costing less than getting a swipe motor for example?

I must add I will never purchase a French car again; trouble after trouble!

In the meantime, I'm just looking for cheaper quick fix options.

19th Oct 2015, 02:17

What was the problem in the end?

2nd Nov 2015, 16:37

Hi, I have a Renault Scenic 16v 2005 model. It does not idle when cold and the accelerator is very sensitive.

7th Nov 2015, 08:32

Had the same problem on my Megane - window went down and wouldn't go back up. Garage charged £80 for the regulator, so I don't know where the £300 comes into play??? Got it done and happy as Larry now!!

24th Dec 2015, 09:24

Sender unit in petrol tank.

28th Mar 2016, 18:43

I have a 2003 Renault Megane 1.6 16V and my radio's screen is showing weird lines and lighting up different parts of the screen. I can't see anything and I now have to enter the unlocking code for the radio, which is pretty much impossible to do considering that I can't see anything. Any ideas on how to solve this? Thanks.

22nd Apr 2016, 18:21

Hi. I have a 2007 Renault Clip Dynamique 2 litre with low mileage. It will not start, but tries to. Had a diagnostics test which states nothing from the ECU. Told that often the wiring into it can go. Is this a common fault or do you think it will be a new ECU? If so, how much would I be expected to pay? Thank you in advance.

24th Jun 2016, 07:31

I have a Renault Megane 1.6 16v Dynamique 03 plate. When I push the starter button, it says the steering is locked, but it's not actually locked, and is totally dead.